Automotive Digital Marketing

Professional Community for Car Dealers, Marketing, Advertising and Sales Leaders

Loading... Be Patient!
I will follow this post up with more information as I learn it, but I wanted to pass this information on and see if this has happened to anyone else lately.

I discovered a huge break in the line of communication this week. I received a report this week stating that we've not responded to any of our GM Internet leads in the past 2 week. The same report sent the week prior rated us a top responder. It seems to flip flop, but our process is hasn't. As I'm digging to find out why this is happening, the rep and I stumble upon a possible disconnection in our CRM to the GM 'lead stop clock." Since we don't have the Cobalt CRM, we could be misrepresented for our response time because it's not set up to work with our CRM.

Our BDC is extremely diligent in responding to leads, and I ride them hard on response time. I even post every single lead on a huge dry erase board in the office every day that displays what time the lead came in to our CRM, time we accepted the lead, and responded to it. I can only wonder how many BDC/Internet managers are getting shortchanged by inaccurate reports.

It seems that when we accept a lead and respond to it through our CRM, it's not being flagged as 'responded to.'

Just a heads up. Has anyone else been able to get to the bottom of something like this? I E-mailed a ticket yesterday and I've been on hold with Auto Base for a while now this morning...you might be able to help me out quicker than they...lol.

Views: 157

Comment

Oops... You need to stop "Lurking" on ADM and become a more genuine Automotive Professional by completing your membership registration. As a registered ADM Member, you can post comments, publish your own articles (be a star!) and start Forum discussions. Stop being an online "Peeping Tom" and JOIN ADM RIGHT NOW!

Join Automotive Digital Marketing


Dealer
Comment by Dana W. Pratt III on June 1, 2009 at 6:47pm
Your story and frustrations I am sure are felt by many. It has taken me 2 years to try and resolve this issue of our CRM (Cobalt's LMCC) not properly reporting lead handling from our BDC. I'm sure it'll never be perfect. Each month the district rep would ask the owner why our report looks so bad. Two district reps later they were still hampering me with this issue. Finally I just started marking every GM lead as sold. So, just the other day the owner brings in the Onstar rep who says we aren't responding to any of our Onstar service notices properly, and on, and on....
Comment by Ralph Paglia on May 31, 2009 at 3:58pm
Megan, we have seen similar problems with GM lead disposition reporting with several other dealers as well. At one point our ADP NetTrak tool was stopping the clock fine, but our webCRM tool was not and we had a difficult time trying to figure out why one was working and the other was not. Then we saw the difference in the Lead Status change reporting and we were able to get it right.

When we piloted the OneSource lead pipe and tool in 2006 I knew that disposition reporting was coming, along with all the 2 way data flow headaches that can come with it. However, most car companies either have had it for awhile or soon will. After all, why should an OEM subsidiZe or send leads to dealers who ether won't respond to them or keep the promise the website made as a reason for the customer to fill out a lead form!

Vendor
Comment by Megan E. Bucher on May 29, 2009 at 12:25pm
Wow, I thought someone else would have the same issue...maybe I was the last to know.
Turns out that there needs to be a specific Disposition ID for a Price Quote Request that GM can recognize and then flag the lead as 'Close' status. It's still not working properly, but at least I've made progress. It sounds like the solution simply hasn't been developed yet. Props to Auto Base support and my GM rep for being so helpful! They rock.

Vendor
Comment by Megan E. Bucher on May 29, 2009 at 8:44am
So, Auto Base is sending GM a notification when an Internet lead is responded to, called, E-mailed, etc. The problem is that nothing flags the price quote. GM requires the status to read 'Closed,' and all of leads are stuck in 'In Progress' status. Odd, because we never give up on a lead unless they ask us not to contact them or the information is invalid. So, technically they are always in progress. What do I need to do to make sure that when Auto Base sends over notification that the price quote E-mail has been sent, it's flagged as 'Close' and the clock stops. Auto Base is instilling everying required by GM.
Who's on first?

Automotive Professional Network and Resource Exchange for Car Dealers, Managers, OEM and Marketing Practitioners seeking Best Practices.

ADM Sponsor

Please Consider Automotive Marketing Professional Community Sponsors

ADM Badge

Loading…

Based On Your Interests...

ADM Consulting, LLC

Onsite/Offsite Combination ADM Consulting, LLC Professional Services
Select the maximum monthly investment you plan to make
$USD
Sign up for

Automotive Marketing Tools

Get ADM Toolbar

Click here to take the ADM Member Survey

Getting too many emails from ADM? Click mailbox below to control which types of alerts and updates you are sent......


Instagram

Top Automotive Marketing Forum Discussions

Share the Best Content w/AutoMarketing Community

© 2019   Created by Ralph Paglia.   Powered by

ADM Badges  |  Report an Issue  |  Terms of Service